Bambora/Wordline service degrated
Incident Report for Noterro
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 11:04 EST
Monitoring
Bambora/Wordline has indicated that they are experiencing degraded service during an emergency maintenance update. Full details and updates can be found here: https://status.na.bambora.com/incidents/dc6l7462yj7w
Posted Mar 06, 2024 - 10:11 EST
This incident affected: Bambora Payments.